db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Van Couvering <da...@vancouvering.com>
Subject Re: Help! Can't connect to DBase
Date Tue, 28 Nov 2006 18:04:23 GMT
It would be very helpful to provide further information around "can't 
connect."  What's the error message and the stack trace?

Also, please run sysinfo and provide that information, knowing which 
version is key.  I have been running Derby in an applet for a sample app 
I am using, and it's never had a problem.

David

Marl Atkins wrote:
> Hi:
> 
> I've got an Applet based application that I've been working on for about 3
> months.
> It creates a Derby database from a MySql database.
> It's been working fine.
> 
> Today, for no apparent reason, the Applet can't connect to the Derby
> database.
> If I use an application with a main proc. in the NetBeans IDE, it still
> works fine.
> 
> I've tried deleting and recreating the database, rebooting . . . 
> The Applet *seems* to be creating the database but then it won't connect to
> it in the next session.
> I connected to it successfully with Squirrel but it didn't see any tables.
> 
> Again, this worked and as far as I recall, I didn't change any code.
> It still works in the IDE. With the Applet it's apparantly returning null
> when I try to create a connection object.
> 
> I'm running Windows 2000 Pro; my browser is IE 6
> 
> Is there an error I could trap besides Exception?
> I'm just looking for some ideas, hoping maybe you've run into something like
> this.
> Right now I'm lost. I have no idea how to solve it.
> 
> Marl K. Atkins
> Microsoft Certified Professional
> SoftLink Systems, Inc.
> (407) 388-1886 
> 
> 

Mime
View raw message