db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: Necessary Packages For Queries
Date Thu, 09 Nov 2006 15:11:38 GMT
Marc Schlegel wrote:
> Hi everybody.
> 
> I am writting an eclipse RCP application and my first plugin is a wrapper to control
the derby database (startup, shutdown, properties,...). 
> 
> In this plugin I want to reexport packages to the using application (just another plugin)
to do queries and so on. My question is which packages are necessary to send and receive queries?
For example I am quite sure that the authentication packages are not essential.

derby.jar is an OSGi bundle and it exports these packages:

org.apache.derby.authentication,
org.apache.derby.database,
org.apache.derby.io,
org.apache.derby.jdbc,
org.apache.derby.vti


If you wanted to subset that then possibly only org.apache.derby.jdbc 
would be required.

Though there hasn't been much testing of derby as an OSGi bundle.

Dan.





Mime
View raw message