db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suresh Thalamati <suresh.thalam...@gmail.com>
Subject Re: Importing data Issue in Derby Databaseusing NetBeans IDE
Date Tue, 07 Nov 2006 21:47:06 GMT
RaghuRam Mynampati wrote:
> hi,
>  
> I am Importing data from and Excel file into Derby database using 
> NetBeans IDE and I am Using procedure for it.
> When I am using it I am getting the following error
>  
>  
> 
> ERROR 42X04: Column COLOUM2 is either not in any table in the 
> 
> FROM list or appears within a join specification and is outside the 
> 
> scope of the join specification or appears in a HAVING clause and is not 
> 
> in the GROUP BY list. If this is a CREATE or ALTER TABLE  statement then
>  
> 
> COLUMN is not a column in the target table."
> 
>  
> 
> PLEASE ANYBODY HELP. I SHOULD FIX THE ISSUE.
> 
> thanks,
> 
> Rags

I have never tried importing data using  Netbeans IDE, but one 
scenario I have seem above error is if the data file does not have 
data for all the columns. For example :

create table t1(a int , b int , c int );

and the data file t1.txt has
1, 2
3, 4

call SYSCS_UTIL.SYSCS_IMPORT_TABLE (null, 'T1', 't1.txt', null, null, 
null, 0)

above import procedure call  will fail, with the same error you are 
seeing.


Another thing I would check is how the columns are separated in the 
file and the format matches with the arguments to import procedure you 
are passing.

I think, the error should be improved for this case.


hope that helps
-suresh



Mime
View raw message