db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Schlegel <Marc.Schle...@gmx.de>
Subject How To Run Derby on a PocketPC?
Date Mon, 21 Aug 2006 15:03:46 GMT
Timothy Luksha wrote:

    Derby should work with j9.   There are two very important things to
    remember
    when attempting to get Derby to run with j2me.  First, do not use
    DriverManager
    to attempt to get a jdbc connection.  j2me does not support this.
     You must
    use a class called embeddedDataSource.  Secondly, j9 does not come
    with an
    implementation of jsr-169 automatically.  This jar is available from
    IBM separately
    and it called jdbc.jar.  I forget where my copy came from but when i
    figure it out I
    will post some instructions.  Derby should work if you remember to
    do those two things.
    ...
    Tim

Hi Tim. Thank you very much for your help and sorry for the late answer
but I moved from Germany to Iceland and had many things to do.

I'm still searching the net, expecially IBM, for this damn jdbc.jar (JSR
169) but I can't find any.
Does anybody know where to get this file?

kind regards
-- Marc


Mime
View raw message