db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren" <m.v.lunte...@gmail.com>
Subject Re: Run Derby with IBMs J9 VM
Date Thu, 27 Jul 2006 17:24:03 GMT
On 7/27/06, Marc Schlegel <Marc.Schlegel@gmx.de> wrote:
> Hi everybody.
>
> I'm trying to get Derby run on the J9 VM on a Windows Mobile 3 Pocket PC.
> If I'm using the binaries I get an UnsupportedClassVersionError (IDE:
> Device Developer 5.6). Because of this I'm currently trying to build the
> derby-src. The problem now is that I need a JDK 1.3 AND 1.4 environment
> to build! But this way I think that I don't get rid of this
> UnsupportedClassVersionError. I've downloaded/imported all necessary
> jar-files (JSR 169, junit, jdbc2_0-stdext).
> Another Problem is that after I've installed the necessary JDKs I still
> get an build-error which says *"[javac] class file has wrong version
> 48.0, should be 47.0" *for the 1.4-javac-tasks??? I've installed
> jdk1.4.2_12.
>
> Please, I need help because it's a project work for the university.
> Thx
>
Hi,
An UnsupportedClassVersionError may indicate a mismatch in libraries
in your classpath. I am wondering if
0. you are running with the foundation or max libraries (with wsdd5.6,
   you cannot run with foundation & derby)
a. it would be possible for you to switch to wctme5.7 (the successor of wsdd5.6)
b. you can successfully run your program outside the JDE, using the j9
executables and libraries.

I've only run wsdd5.6 on straight Windows (2000), so I'm not sure this
is exactly portable, but on windows 2000 I'd could evade the IDE with
a command like so:
  j9 -jcl:max -Xbootclasspath/p:c:/wsdd5.6/ive/lib/jclMax/classes.zip;c:/wsdd5.6/ive/lib/charconv.zip;c:/wsdd5.6/ive/lib/jclMax
org.apache.derby.tools.ij to start ij (I'm assuming you've gotten the
jdbc classes, mine installed into jclMax).
    I believe that if you have $JAVA_HOME set to wsdd5.6/bin you
shouldn't even need the classes.zip and charconv.zip in the
bootclasspath.
If you can get your class to go without the IDE, you can start digging
for the offending setting...

Regarding the build error, maybe someone else can speak up on that, if
you follow the instructions in the BUILDING.txt you should be able to
get it going...Although...I've never tried building on a Pocket PC.
Maybe you can post the contents of your ant.properties?

hth
Myrna

Mime
View raw message