db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ray Kiddy <kid...@apple.com>
Subject Re: BigDecimal incompatibility from 1.5 -> 1.4
Date Thu, 13 Jul 2006 18:25:46 GMT

On Jul 13, 2006, at 11:01 AM, Craig L Russell wrote:

> Hi Ray,
>
> This sounds like a bug in the compiler. Have you raised an issue  
> with the JDK folks?
>
> Craig
>

It had not occurred to me to look at this as a bug in the 1.5 javac.  
I think I will file that with Sun. I was just thinking that the 1.4.2  
compiler was, you know, done.

- ray

> On Jul 13, 2006, at 9:38 AM, Ray Kiddy wrote:
>
>>
>> I have been e-mailing with Andrew McIntyre about getting some  
>> things done in the build of Derby on Mac OS X.
>>
>> We (at Apple) are seeing something and I am wondering how you all  
>> have dealt with this issue. At one time, we thought we could use  
>> Java 1.5 and achieve backwards compatibility with 1.4. We have  
>> seen an issue with BigDecimal and I wonder if this has impacted  
>> you all, or how you have dealt with it.
>>
>> The problem is this. If one used a method in 1.4,  
>> java.math.BigDecimal(int), the javac compiler would map this for  
>> you, under the covers, to java.math.BigDecimal(double).
>>
<snip>



Mime
View raw message