db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susan Cline <home4...@pacbell.net>
Subject Re: Creator 2 + Derby 10.1.2.1 == true?
Date Tue, 04 Apr 2006 16:50:48 GMT
--- dan <dan@elvberg.com> wrote:

> Hi
> I'm fairly new to Creator 2 and brand new to Derby...
> Can I use Derby in the Creator IDE? /dan
> 
> 
Hi Dan,

I have not used it before, but it looks like others have with
older versions of Derby so it should work fine with Derby 10.1.2.1.

A google turned up this link that had some info:

http://forum.java.sun.com/thread.jspa?threadID=572721&messageID=2838959

It appears in that post they were using Derby 10.0 instead of Derby 10.1 and
were using the DB2 JDBC driver to connect to Derby when running the network
server.  The preferred method to connect to the network server in Derby 10.1 is
via the Derby Client Driver.  So in the post cited above you should look at the 
Derby documentation about how to connect via the Client Driver instead of the 
post which uses the DB2 JDBC Driver.

http://db.apache.org/derby/docs/10.1/adminguide/cadminappsclient.html

For instance the DB2 driver used roughly this syntax jdbc:derby:net://localhost:1527/myDB
and the Derby Client Driver uses jdbc:derby://localhost:1527/myDB.

Susan

Mime
View raw message