Daniel John Debrunner schrieb:
Boris Hoffmann wrote:

  
Hi there,

has anybody tried to get around with derby using ewe jvm? -->
http://www.ewesoft.com/
My Problem is that i'm unable to start the derby-db because of this
exception:
    

heir site is a little vague about what exactly the EWE VM is. E.g. this
sentence would worry me :-)

<quote>
No, the Ewe VM is not a Java VM since it does not implement a very small
number of Java features, nor does it use any of the "standard" Java
libraries and API
</quote>

Once you get into the details (though these are hard to find, several
links give errors), you do indeed find that this is not a Java VM, it's
a non-standard VM that shares some minor elements with a Java VM.
(http://www.ewesoft.com/UnderTheHood.htm)

Thus I would say near zero chance of Derby running on it, since Derby is
targeted at the standard J2ME/CDC/Foundation and J2SE apis.


Dan.


  
Thanks for the fast answer.
OK, so i have to change the VM, using a REAL java VM :)

thx again
Boris