Hi Xavier,
 
The class org/eclipse/jdt/internal/launching/JavaLocalApplicationLaunchConfigurationDelegate is not available in 3.1M6, however it is available in 3.1M5 and earlier (3.0 --> 3.1M5)
 
Can you please log a bug in JIRA in the 'Tools' component category to add support for
Eclipse 3.1M6 for the UI plug-in, mentioning the missing class in 3.1M6?
 
Thanks,
 
Susan

Xavier <xcoulon@gmail.com> wrote:
Yes,

The project's classpath includes :
db2jcc_license_c.jar
db2jcc.jar
derby.jar
derbynet.jar
derbytools.jar

On the other side, I cannot find the class
'StartDerbyServerLaunchConfigurationDelegate' in any jar of the eclipse
plugins on my machine.. which seems to be the real problem, as written
in the log file.
I run the version 3.1M6.. is this class available in previous milestones ?

Xavier

Dan Scott wrote:
> On 5/26/05, Xavier wrote:
>
>>Hello,
>>
>>I am currently using Eclipse 3.1M6 bundled with the WebTools project. I
>>added the Derby plugin 10.0.2 (with the manually modified version number
>>in the plugin.xml file), along with the IBM Cloudscape UI plugin 1.0.0
>>to 'add erby nature' to my java project, then start and stop the derby
>>network server. Hélas, when trying to start the network server, I get an
>>error popup with the following message :
>>"Error starting Derby Network Server :
>> Pluging com.ibm.clouscape.ui was unable to load class
>> com.ibm.clouscape.ui.launch.StartDerbyServerLaunchConfigurationDelegate".
>>
>>When i look at the .log file in the workspace's metadata directory, I
>>get the following error :
>>
>>!ENTRY org.eclipse.core.runtime 4 1 2005-05-26 16:51:30.538
>>!MESSAGE Plug-in com.ibm.cloudscape.ui was unable to load class
>>com.ibm.cloudscape.ui.launch.StartDerbyServerLaunchConfigurationDelegate.
>>!STACK 0
>>java.lang.NoClassDefFoundError:
>>org/eclipse/jdt/internal/launching/JavaLocalApplicationLaunchConfigurationDelegate
>>
>>
>>Any idea ?
>>
>>Thank you in advance.
>>Xavier.
>>
>>
>
>
> Does your CLASSPATH environment variable specify the required derby JARs?
>
> Dan
>