db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew McIntyre <fuzzylo...@sbcglobal.net>
Subject Re: Derby, CodeWarrior and MRJ
Date Thu, 03 Feb 2005 18:54:38 GMT

On Feb 3, 2005, at 9:43 AM, Daniel John Debrunner wrote:

> Is there a newer JVM (1.3 or later) for MacOS 9.1 or later 9.x 
> versions?

Nope. Development of MRJ ceased at 2.2.6, and that was also only up to 
the JDK 1.1.8 spec. Apple released its first JDK 1.3 JVM with Mac OS X. 
As far as I am aware, there are also no third-party JVMs for MacOS 9.x. 
In fact, I have open bugs that I filed with Apple using an old version 
of Cloudscape (3.5, i think) with MRJ. I'm guessing that those will 
never be fixed.

> In my situation, I have never bothered to upgrade the iMac at home to
> MacOS X because I'm not sure what value I would get given the 
> computer's
> use. So this may be a common situation.

Even for surfing the web, the ability to use a more modern web browser 
would be attractive, although Mozilla 1.2.1 does still work quite well. 
Personally, I enjoy having real multitasking and BSD underneath the 
covers. But if you're interested in developing something in Java, the 
ability to use a JDK 1.3 (or higher) JVM on your computer might be a 
significant reason to upgrade. :-)

andrew


Mime
View raw message