db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lance J. Andersen" <Lance.Ander...@Sun.COM>
Subject Re: Problems in building Derby
Date Thu, 06 Jan 2005 18:34:28 GMT
The build files are particular to the exact name of the servlet jar.  If 
read the required doc page again, you will find a URL to where you can 
download the needed jar.

I hit this myself even though I had the correct servlet classes and this 
was how I worked around it.

Bernd Ruehlicke wrote:

>Yea - I had same problem. It looks like only the servlet.jar is needed.
>Lucky I had one and the build worked fine. The one I had was 40k. I've
>looked around and you can find "a" servlet.jar in the Tomcat
>distributions which might work - look under
>
>http://jakarta.apache.org/site/binindex.cgi#tomcat
>
>Try the servlet.jar in the 4.1.31 release. 
>
>Good luck
>B-)
>
>  
>
>>-----Original Message-----
>>From: Jean T. Anderson [mailto:jta@bristowhill.com] 
>>Sent: Thursday, January 06, 2005 12:15 PM
>>To: Derby Discussion
>>Subject: Re: Problems in building Derby
>>
>>For that entry in 
>>http://incubator.apache.org/derby/derby_downloads.html
>>there is also a link to this email thread:
>>http://mail-archives.apache.org/eyebrowse/BrowseList?listName=
>>derby-dev@db.apache.org&by=subject&from=658425&to=658425&first
>>=1&count=2
>>
>>Does that help for the short-term?
>>
>>For long-term, does anyone know where the new official home is for
>>jakarta-servletapi-4 ?
>>
>> -jean
>>
>>
>>federicogiallo@aliceposta.it wrote:
>>
>>    
>>
>>>Hi
>>>
>>>Two days ago I installed Apache Derby 10.0.2.1, and followed the 
>>>instruction to configure the environment.
>>>Unfortunately I didn't succeed in downloading and installing 
>>>      
>>>
>>one of the 
>>    
>>
>>>software components needed according to your Building 
>>>      
>>>
>>instruction, the 
>>    
>>
>>>jakarta- servlet API 4 (Servlet 2.4).
>>>In fact it's impossible to find and download it at the url 
>>>      
>>>
>>suggested (http:
>>    
>>
>>>//cvs.apache.org/builds/jakarta-servletapi-4/nightly/).
>>>My environment variables have been as follows:
>>>PATH :
>>>C:\Ant;C:\Ant\bin;C:\Cloudscape_10.0\frameworks\embedded\bin;
>>>      
>>>
>>C:\j2sdk1.
>>    
>>
>>>4.2_06\bin; 
>>>C:\jdk1.3.1_15\bin;%JAVA_HOME%\bin;%J2EE_HOME%\bin;%ANT_HOME%\bin; 
>>>C:\Sun\AppServer\bin; %path%; CLASSPATH :
>>>C:\j2sdk1.4.2_06\lib\tools.jar;C:\jdk1.3.1_15\lib\tools.jar;C
>>>      
>>>
>>:\j2sdk1.4.2_06\JRE\lib\rt.
>>    
>>
>>>jar;C:\j2sdk1.4.2_06\lib\tools.jar;%CLOUDSCAPE_INSTALL%\lib\d
>>>      
>>>
>>erby.jar;%
>>    
>>
>>>CLOUDSCAPE_INSTALL% 
>>>\lib\derbytools.jar;%CLOUDSCAPE_INSTALL%\lib\derbynet;%CLOUDS
>>>      
>>>
>>CAPE_INSTA
>>    
>>
>>>LL% 
>>>\lib\db2jcc;%CLOUDSCAPE_INSTALL%\lib\db2jcc_license_c;C:\Ant\
>>>      
>>>
>>lib\xercesImpl.
>>    
>>
>>>jar;C:\Ant\lib\xml-apis.jar;
>>>
>>>When I tried to build the project with ant, I received the 
>>>      
>>>
>>following error:
>>    
>>
>>>[Javac] Fatal error: Unable to locate package Java.lang in 
>>>      
>>>
>>classpath, 
>>    
>>
>>>or boot path.
>>>
>>>Can you help me with this problem?
>>>It's possible to download jakarta-servlet API 4 (Servlet 
>>>      
>>>
>>2.4) in some 
>>    
>>
>>>mirror site?
>>>
>>>Thank you
>>>
>>>  Federico Giallombardo
>>>
>>>
>>> 
>>>
>>>      
>>>
>
>  
>

Mime
View raw message