db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-7038) Upgrade ant version and re-write javadoc build targets to use improved <javadoc>task
Date Tue, 14 May 2019 02:11:00 GMT

    [ https://issues.apache.org/jira/browse/DERBY-7038?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16839023#comment-16839023
] 

ASF subversion and git services commented on DERBY-7038:
--------------------------------------------------------

Commit 1859203 from Richard N. Hillegas in branch 'code/trunk'
[ https://svn.apache.org/r1859203 ]

DERBY-7038: Revert the javadoc build to use the <javadoc> task rather than the <exec>
task; commit derby-7038-02-aa-use-ant-javadoc-task.diff.

> Upgrade ant version and re-write javadoc build targets to use improved <javadoc>task
> ------------------------------------------------------------------------------------
>
>                 Key: DERBY-7038
>                 URL: https://issues.apache.org/jira/browse/DERBY-7038
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.16.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>            Priority: Major
>         Attachments: derby-7038-01-aa-require-Ant-1.10.6.diff, derby-7038-02-aa-use-ant-javadoc-task.diff
>
>
> Version 1.10.6 of ant will enhance the <javadoc> task in order to understand some
of the module-aware switches introduced by Java 9. Currently, our javadoc targets work around
the limitations of the <javadoc> task by running javadoc via the <java> task.
We should upgrade our version of ant and re-write the javadoc targets to take advantage of
the improvements introduced by ant 1.10.16 (see https://dist.apache.org/repos/dist/dev/ant/RELEASE-NOTES-1.10.6.html).
I imagine this work will occur in 3 phases:
> 1) Upgrade the Jenkins scripts to require ant 1.10.6.
> 2) Upgrade our build scripts to require ant 1.10.6.
> 3) Re-wire our javadoc targets.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message