db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Pendleton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-6848) Unable to start derbyNetworkServer.bat
Date Wed, 23 Dec 2015 15:05:46 GMT

    [ https://issues.apache.org/jira/browse/DERBY-6848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15069709#comment-15069709

Bryan Pendleton commented on DERBY-6848:

What was in output1.txt and output2.txt?

The stack trace in permission-output.txt appears to show that the Network Server
received a security manager exception, attempted to print it to the console,
and then called System.exit(), and System.exit() perhaps threw another
security manager exception because whatever policy was in place did not
give the Network Server the right to use System.exit().

I don't typically run the Network Server with a non-default locale, but I see
a message in permission-output.txt: 

scl:  getPermissions ProtectionDomain  (file:/D:/java/jdk8/jre/lib/ext/localedata.jar <no
signer certificates>)
 <no principals>
 java.security.Permissions@300ffa5d (
 ("java.io.FilePermission" "\D:\java\jdk8\jre\lib\ext\localedata.jar" "read")

And then the next thing in that file is a stack trace showing that NetworkServerControl.main
has called System.exit.

So perhaps the security manager is not allowing the Network Server to access the
locale information in D:\java\jdk8\jre\lib\ext\localedata.jar, and that would explain
why you encounter this problem, but users who are not using a special locale
do not have a problem? 

Perhaps you could follow the procedure described here:
to give the Network Server a custom security policy file, and ensure that
your security policy file has entries authorizing access to the locale data?

Another thing you might try, along these lines, is to explicitly grant the exitVM
permission, because I see a message:

scl:  getPermissions ProtectionDomain  (file:/D:/java/db-derby-
<no signer certificates>)
 <no principals>
 java.security.Permissions@448139f0 (
 ("java.lang.RuntimePermission" "exitVM")
 ("java.io.FilePermission" "\D:\java\db-derby-\lib\derbyclient.jar" "read")

in permission-output.txt, and I am not sure that Derby's default policy grants

permission java.lang.RuntimePermission "exitVM";

for any of the Derby jars, though I don't recall any problems with that permission in the

> Unable to start derbyNetworkServer.bat
> --------------------------------------
>                 Key: DERBY-6848
>                 URL: https://issues.apache.org/jira/browse/DERBY-6848
>             Project: Derby
>          Issue Type: Bug
>          Components: Network Server
>    Affects Versions:,
>         Environment: Windows 7 x64 Russian Encoding
> Java 8. _25 _66 _65
>            Reporter: Vlasov Igor
>         Attachments: derby_networkserver.png, derby_networkserver2.png, run-script-console-screenshot.jpg,
run-script-output.txt, run-script.bat
> I tried to call startNetworkServer.bat.
> The only way to start derby in my enviroment is to use "-noSecurityManager"
> argument
> Atnother way is halting executiong without any message.
> Tried to start from: 
> 1)jdk/db/bin
> 2)Download db-derby- and extract to folder.

This message was sent by Atlassian JIRA

View raw message