db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@gmail.com>
Subject Re: can't log onto people.apache.org in order to upload the 10.12.1 release candidate
Date Mon, 14 Sep 2015 13:54:36 GMT
Problem fixed. Pilot error. I had registered my fingerprint rather than 
my whole public key at https://id.apache.org. You need to register the 
whole public key, including the trailing machine identifier.

Cheers,
-Rick

On 9/13/15 7:48 PM, Rick Hillegas wrote:
> The security of committer accounts has been increased. I can no longer 
> log onto people.apache.org. I have sent the following message to the 
> infrastructure list. Maybe someone on this list can give me advice in 
> the meantime:
>
> --------------
>
> I am unable to log onto my people.apache.org account. The following 
> command...
>
>   ssh rhillegas@people.apache.org
>
> ...gives me this diagnostic...
>
> "Note: logging in to this server with a password has been disabled.
>
> Please see : 
> https://blogs.apache.org/infra/entry/committer_shell_access_to_people
>
> Remember to load your ssh key:-
>
> See: http://linux.die.net/man/1/ssh-add
> See: http://linux.die.net/man/1/ssh-agent
>
> Permission denied (publickey)."
>
> I have been trying to follow the instructions at 
> https://blogs.apache.org/infra/entry/committer_shell_access_to_people 
> without any success. I have gone so far as to do the following:
>
> 1) Deleted all the files under ~/.ssh
>
> 2) Created new credentials thusly...
>
>   ssh-keygen -t rsa
>
> 3) Started an ssh agent thusly...
>
>   eval `ssh-agent`
>
> 4) Added my identity to the agent thusly...
>
>   ssh-add
>
> Note that that appears to have worked because the following command 
> returned status 0...
>
>   echo $?
>
> 5) Logged onto https://id.apache.org and successfully recorded the key 
> fingerprint from step 2) above. At least I was thrown onto a page with 
> this cheerful message:
>
>   "Details change successful"
>
> 6) Waited 5 minutes and tried to log onto people.apache.org. But I 
> received the original diagnostic.
>
> 7) Tried again 10 minutes later. Still no joy.
>
> Any suggestions about what I am doing wrong?
>
> Thanks,
> -Rick


Mime
View raw message