db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Matrigali (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-6391) remove unneeded object creation in newException() calls in releases > 10.10
Date Wed, 23 Oct 2013 19:53:45 GMT

    [ https://issues.apache.org/jira/browse/DERBY-6391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13803234#comment-13803234
] 

Mike Matrigali commented on DERBY-6391:
---------------------------------------

note, do not backport any such change to 10.10 or previous release.  It will not work.

> remove unneeded object creation in newException() calls in releases > 10.10
> ---------------------------------------------------------------------------
>
>                 Key: DERBY-6391
>                 URL: https://issues.apache.org/jira/browse/DERBY-6391
>             Project: Derby
>          Issue Type: Improvement
>    Affects Versions: 10.11.0.0
>            Reporter: Mike Matrigali
>              Labels: derby_backport_reject_10_10
>
> In releases after 10.10 the code has been converted to use new 
> java language features.  One of the benefits I just noticed is that
> arguments to StandardException.newException() no longer have
> to be Objects.  I believe this is due to reimplementation using varargs.
> As an example old code use to have to be written as:
> throw StandardException.newException(
>                     SQLState.FILE_BAD_CHECKSUM,
>                     id,
>                     new Long(checksum.getValue()),
>                     new Long(onDiskChecksum),
>                     pagedataToHexDump(pageData));
> The only reason for the new Long() calls was to make them Objects so
> that the call would match up to a hard coded N Object arg version of
> the newException call.  I believe these conversions to Objects are no
> longer needed (but formatting of the args might change).
> There may be code size savings to be had by doing this code
> rototil.
> Anyone see a downside to changing the code in this way?



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message