db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Pendleton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-6291) Improve code coverage of org.apache.derby.iapi.jdbc.BrokeredCallableStatement
Date Fri, 12 Jul 2013 22:55:50 GMT

    [ https://issues.apache.org/jira/browse/DERBY-6291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13707500#comment-13707500
] 

Bryan Pendleton commented on DERBY-6291:
----------------------------------------

When you see the "30", "40", "42" etc references in Derby code, it often refers to a
particular version of the Java JDBC spec.

So there was JDBC version 3.0, JDBC version 4.0, JDBC version 4.1, etc.

And those different JDBC versions work with different versions of the JDK.

Since JDBC (and Java) have been around for 20 years, there have come
to be a lot of versions, and it is complicated to keep track of them, so the
Derby code has to be very aware of which JDBC version is in use by a particular
application and version of the JDK.

So some of the code that you see might only run if JDK version 1.4 is used, or Java 5,
or Java 6, or Java 7, etc.

                
> Improve code coverage of  org.apache.derby.iapi.jdbc.BrokeredCallableStatement
> ------------------------------------------------------------------------------
>
>                 Key: DERBY-6291
>                 URL: https://issues.apache.org/jira/browse/DERBY-6291
>             Project: Derby
>          Issue Type: Sub-task
>          Components: JDBC
>            Reporter: ahsan shamsudeen
>            Assignee: ahsan shamsudeen
>            Priority: Minor
>
> According to code coverage analysis, org.apache.derby.iapi.jdbc.BrokeredCallableStatement
is 
> exercised poorly by of our regression tests. The current coverage report for this class
can be found at http://dbtg.foundry.sun.com/derby/test/coverage/_files/a9.html
> This task is to investigate this class, and either remove the unused code, or add
> regression test that exercise the code, as appropriate.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message