db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-5840) Clean up compiler warnings introduced by using Java 5 language features
Date Tue, 21 May 2013 20:01:15 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5840?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Knut Anders Hatlen updated DERBY-5840:

    Attachment: derby-5840-14-aa-bigdecimal.diff

Attaching derby-5840-14-aa-bigdecimal.diff which removes the suppression of an unchecked warning
in NumberDataType.setBigDecimal().

The method takes a BigDecimal argument. However, its declared type is Number in order to compile
on CDC. The method needs to call BigDecimal's compareTo() method, so it casts it to Comparable,
which is a generic type in Java 5, and the cast causes an unchecked conversion warning.

Since the support for CDC is dropped on trunk, the parameter type can now be BigDecimal. The
patch changes the signature of the setBigDecimal() method in DataValueDescriptor and all overrides.

Also, since CDC isn't supported, the patch removes the CDC-specific implementation classes
rather than updating them with the new signatures. The following classes are removed:


All regression tests ran cleanly with the patch.
> Clean up compiler warnings introduced by using Java 5 language features
> -----------------------------------------------------------------------
>                 Key: DERBY-5840
>                 URL: https://issues.apache.org/jira/browse/DERBY-5840
>             Project: Derby
>          Issue Type: Improvement
>          Components: Miscellaneous
>    Affects Versions:
>            Reporter: Rick Hillegas
>         Attachments: derby-5840-01-aa-compatibilityTests.diff, derby-5840-02-aa-compatibilityTests-again.diff.txt,
derby-5840-03-aa-drda.diff, derby-5840-03-ab-drda.diff, derby-5840-04-aa-client-level.diff,
derby-5840-05-aa-client-deprecation.diff, derby-5840-06-aa-jdbc3-stubs.diff, derby-5840-07-aa-drda-for-each.diff,
derby-5840-08-aa-jdbc3-embedded.diff, derby-5840-09-aa-test-deprecation-and-unchecked.diff,
derby-5840-10-aa-derbynet-perf-system.diff, derby-5840-11-aa-engine-i18n-store-tools.diff,
derby-5840-12-aa-jdbcapi.diff, derby-5840-13-aa.diff, derby-5840-13-aa-remove-suppression.diff,
> Using Java 5 language features forces us to compile code at level 5 or higher. At this
level, the compiler raises warnings not seen at lower levels. This issue is a place to discuss
and attach cleanup to eliminate these warnings.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message