db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: expected behavior when running 10.11 against jvm previous to 1.6?
Date Fri, 10 May 2013 18:39:07 GMT
On 5/10/13 11:17 AM, Mike Matrigali wrote:
> If it is not too hard I wonder if we should disable derby from booting 
> if the jvm is not 1.6 or higher, with hopefully a clear message saying
> why the boot is failing.
>
>
Hi Mike,

I'm not sure we can do much here. The compiled Derby byte code will be 
Java 6 byte code. If you try to run Java 6 byte code on an older VM you 
will get a java.lang.UnsupportedClassVersionError. This error is raised 
as the VM tries to load Derby, that is, long before we have an 
opportunity to inject an explanatory message.

But perhaps someone else has a clever idea.

Thanks,
-Rick

Mime
View raw message