db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Matrigali (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DERBY-6178) AutoloadTest does not proprogate original jvm -D flags to spawned JVM, leading to LAB regression test failures
Date Mon, 15 Apr 2013 16:54:17 GMT

     [ https://issues.apache.org/jira/browse/DERBY-6178?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mike Matrigali resolved DERBY-6178.
-----------------------------------

    Resolution: Fixed

I am resolving this issue and plan on resolving and closing as duplicate all the outstanding

AutoloadTest issues that were encountered in IBM lab runs.  I have filed a new issue to
track work on fixing the test to correctly handle non-default baseports rather than just disabling
the test.  I tried fixing the test but did not have time to get it working.
                
> AutoloadTest does not proprogate original jvm -D flags to spawned JVM, leading to LAB
regression test failures
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-6178
>                 URL: https://issues.apache.org/jira/browse/DERBY-6178
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.10.1.2, 10.9.2.2, 10.11.0.0
>            Reporter: Mike Matrigali
>            Assignee: Mike Matrigali
>            Priority: Critical
>              Labels: derby_backport_reject_10_8
>             Fix For: 10.10.1.2, 10.9.2.2, 10.11.0.0
>
>         Attachments: derby-6178.diff
>
>
> IBM lab nightly regression testing is seeing numerious intermittent errors while running
the
> AutoloadTest.   This regression testing often runs multiple runs of Suites.all on the
same machine at
> the same time and uses the -Dderby.tests.basePort=3500 option to the tests to insure
network
> server is created on different ports and don't intefere.
> I think the following code in this test that spawn a process is not going pass that port
info onto the network
> server startup and then lead to problems:
>     /**
>      * Run {@code AutoloadTest} in a separate JVM.
>      */
>     public void spawnProcess() throws Exception {
>         String[] cmd = {
>             "junit.textui.TestRunner", spawnedTestClass.getName()
>         };
>         SpawnedProcess proc =
>             new SpawnedProcess(execJavaCmd(cmd), spawnedTestClass.getName());
>         if (proc.complete() != 0) {
>             fail(proc.getFailMessage("Test process failed"));
>         }
>     }

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message