db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: Problem to use java classes in Derby
Date Wed, 17 Apr 2013 17:49:39 GMT
On 4/15/13 10:51 AM, philippe02 wrote:
> Hello
>
>   I have the same problem as below
>
> http://apache-database.10148.n7.nabble.com/Problems-create-SQL-Function-td106464.html.
Hi Philippe,

That error message covers a lot of problems. The email thread you 
referenced shows that the user's code had to be corrected in several 
ways. We might be able to give better advice if you could include your 
CREATE FUNCTION statement and the signature of your public static Java 
method.

Thanks,
-Rick
> I have the same problem and I can't resolve it. I looked in forums, Google
> etc for many long time and I have always the same message.
> ERROR 42X51: The class 'Myclass' does not exist or is inaccessible. This can
> happen if the class is not public.
>
> All in my class is Public and I tried many samples for the same result....
>
> I want to copy rows from Derby tables to SQL server via a trigger "after
> insert". I created a class that works properly with eclipse and JDBC. I
> can't insert this class in Derby.
>
> Could you help me ?
>
> Thanks
>
> Philippe
>
>
>
>
> --
> View this message in context: http://apache-database.10148.n7.nabble.com/Problem-to-use-java-classes-in-Derby-tp129202.html
> Sent from the Apache Derby Developers mailing list archive at Nabble.com.
>


Mime
View raw message