db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <knut.hat...@oracle.com>
Subject Re: encoding problems with Japanese variants of the user docs
Date Wed, 13 Mar 2013 11:03:12 GMT
Rick Hillegas <rick.hillegas@oracle.com> writes:

> Three questions:
>
> 1) How do I build the website with the correct encoding so that links
> to the Japanese docs don't appear as strings of question marks?

I think you need to run forrest with your system locale set to some
variant that uses UTF-8. I am able to reproduce the garbled links if I
set the environment variable LANG=C before I run "forrest site". The
links are not garbled when I run with LANG=en_US.UTF-8.

> 2) Similarly, how do I build the Japanese docs so that the encoding
> will be correct when they are checked into the website?

This doesn't only affect the Japanese (or the Portuguese) manuals, by
the way. See for example
http://db.apache.org/derby/docs/10.9/getstart/cgsusingtoolsutils.html
where the non-breaking spaces have been replaced with ??.

I don't know how this happened. However, since all versions of the
manuals on the website seem to be garbled, and I assume the already
released manuals weren't rebuilt when we did the website migration last
year, I don't think this is a problem with how the docs are built, but
rather with how they were copied into the site repository.

Do the Japanese manuals look right just after you've built them in your
environment, before you've copied them to the site repository? What kind
of tool do you use to copy the manuals?

> 3) How do I get credentials so that I can log onto builds.apache.org?

Per https://wiki.apache.org/general/Jenkins you need to ask the DB PMC
chair to grant you access. That will give you access to
builds.apache.org via the Jenkins web interface. You still won't be able
to log in with ssh.

> More context below...
>
> I am removing outdated versions of the Japanese and Brazilian docs as
> described here: https://issues.apache.org/jira/browse/DERBY-6106 In
> the process, I seem to have tripped across the encoding problems which
> cause Japanese text to appear as ? on the website. This includes
> Japanese text in links on the website's doc tab as well as all the
> text in the Japanese variants themselves.
>
> Does anyone know how to fix this problem and get the encoding correct?
> The topic was discussed on DERBY-6023 but there are no instructions
> there on how one fixes one's own builds. For instance, what is the
> correct encoding and how do you force it?
>
> I thought that I could finesse part of the problem by logging onto
> builds.apache.org in order to retrieve an alpha build of the Japanese
> docs. (The alpha builds of the Japanese docs display correctly). But I
> can't ssh to builds.apache.org: Permission denied
> (publickey,keyboard-interactive).

You might be able to retrieve the latest Japanese docs by going to

https://builds.apache.org/job/Derby-docs/lastSuccessfulBuild/artifact/trunk/out/ja_JP/

and clicking the "all files in zip" link. That should give you a zip
file that contains the entire directory.

-- 
Knut Anders

Mime
View raw message