db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "fpientka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5938) Documentation says Derby works with Java 1.4.2
Date Mon, 18 Mar 2013 20:35:15 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5938?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13605595#comment-13605595
] 

fpientka commented on DERBY-5938:
---------------------------------

one more correction for the javadoc text jdbc3\overview-summary.html, jdbc4\overview-summary.html
and the index.html file
 "Derby runs on any J2SE 1.4.2 or higher virtual machine "
should be replaced with the correct info in the release note
"Java SE 5 and higher with JDBC 3.0, 4.0, 4.1, and 4.2."
so derby 10.10 supports java 5 or higher, but not anymore java 1.4 
                
> Documentation says Derby works with Java 1.4.2
> ----------------------------------------------
>
>                 Key: DERBY-5938
>                 URL: https://issues.apache.org/jira/browse/DERBY-5938
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.10.1.1
>            Reporter: Knut Anders Hatlen
>            Assignee: Kim Haase
>             Fix For: 10.10.1.1
>
>         Attachments: DERBY-5938.diff, DERBY-5938.stat, DERBY-5938.zip
>
>
> The documentation says that Derby works with Java 1.4.2. This is not true on trunk, as
support for Java 1.4.2 is removed for Derby 10.10. A quick search came up with these places
that need change:
> * Getting started guide:
> http://db.apache.org/derby/docs/dev/getstart/tgssetupverify.html
> http://db.apache.org/derby/docs/dev/getstart/cgstutorialintro.html
> http://db.apache.org/derby/docs/dev/getstart/tgssetupjavaenvir.html
> http://db.apache.org/derby/docs/dev/getstart/cgsintsr.html
> Need to change the above topics to say that you need JDK 1.5 or later installed to run
the examples.
> * Developer's guide:
> http://db.apache.org/derby/docs/dev/devguide/rdevconcepts713.html
> The cell for the combination Multi-User/Embedded mentions potential multi-boot problems
in pre-1.4 JVMs. Derby doesn't run on pre-1.4 JVMs anymore (and hasn't done for a long time).
However, the multi-boot problem is present on CDC/FP 1.1, which is still a supported platform,
so maybe we should change "pre-1.4" to "J2ME" (or however we usually refer to that platform
in the docs).
> * Admin guide:
> http://db.apache.org/derby/docs/dev/adminguide/cadminappsthenetworkserverandjvms.html
> Should say that the server is compatible with Java 5 and above.
> * Tools guide:
> http://db.apache.org/derby/docs/dev/tools/ctools1003034.html
> Although it's technically correct that the tools do run on Java 1.4, it's not possible
to access a Derby database with them on Java 1.4 in any supported way (unsupported way: use
derbytools.jar from 10.10 and derby.jar from 10.9). So we should change this topic to say
Java 5 and above, perhaps also mentioning CDC/Foundation Profile 1.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message