db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-6061) Upgrade language is inconsistent
Date Tue, 05 Feb 2013 16:46:11 GMT

     [ https://issues.apache.org/jira/browse/DERBY-6061?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Kim Haase updated DERBY-6061:

    Attachment: DERBY-6061-code2.stat

Attaching DERBY-6061-2.diff, DERBY-6061.stat, and DERBY-6061.zip, with the following Developer's
Guide changes:

D       src/devguide/tdevupgradesoft.dita
M       src/devguide/cdevcsecureroles.dita
M       src/devguide/tdevupgradedb.dita
M       src/devguide/derbydev.ditamap

Also attaching DERBY-6061-code2.diff and DERBY-6061-code2.stat, with the following code changes:

M       java/engine/org/apache/derby/loc/messages.xml
M       java/engine/org/apache/derby/loc/messages_it.properties
M       java/testing/org/apache/derbyTesting/functionTests/tests/lang/ErrorCodeTest.java

I hope these help make the upgrade documentation and terminology more clear and consistent.
> Upgrade language is inconsistent
> --------------------------------
>                 Key: DERBY-6061
>                 URL: https://issues.apache.org/jira/browse/DERBY-6061
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions:
>            Reporter: Kim Haase
>            Priority: Minor
>         Attachments: cdevcsecureroles.html, DERBY-6061-2.diff, DERBY-6061-code2.diff,
DERBY-6061-code2.stat, DERBY-6061-code.diff, DERBY-6061.diff, DERBY-6061.stat, DERBY-6061.zip
> In the Developer's Guide we describe two kinds of upgrade, "full" and "soft". I think
we used to use the terms "hard" and "soft", and "hard" was changed to "full" to provide a
more accurate description of what happens. There are still a few leftover occurrences of "hard"
in the docs here and there.
> However, "soft" doesn't provide much indication of what happens in that kind of upgrade.
Would "partial" be more correct? If not, is there a good alternative?
> I can go through the docs and fix the language based on whatever you all think makes

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message