db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-6061) Upgrade language is inconsistent
Date Mon, 04 Feb 2013 21:50:13 GMT

    [ https://issues.apache.org/jira/browse/DERBY-6061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13570660#comment-13570660
] 

Kim Haase commented on DERBY-6061:
----------------------------------

I'm afraid I'm getting cold feet on this. We've been making the full upgrade/soft upgrade
distinction since 10.2. References to soft upgrade seem to be limited to the Developer's Guide
and Reference Manual upgrade topics; references to full upgrade are scattered here and there.
I think it might confuse people more if we change the terminology than if we don't. It's probably
more important to be consistent in our language than to try to find exactly correct terminology.

We should get rid of references to "hard upgrade". I find only two references to hard upgrade
in the docs. There's one sentence in http://db.apache.org/derby/docs/10.9/devguide/cdevcsecureroles.html,
which at this point should probably be removed entirely:

"Old databases must be (hard) upgraded to at least Release 10.5 before roles can be used."

There's also an error message in the error message list:

08004 -- User '<authorizationID>' cannot hard upgrade database '<databaseName>'.
Only the database owner can perform this operation.

It would probably be simple enough to remove "hard" from this message.
                
> Upgrade language is inconsistent
> --------------------------------
>
>                 Key: DERBY-6061
>                 URL: https://issues.apache.org/jira/browse/DERBY-6061
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.9.1.0
>            Reporter: Kim Haase
>            Priority: Minor
>
> In the Developer's Guide we describe two kinds of upgrade, "full" and "soft". I think
we used to use the terms "hard" and "soft", and "hard" was changed to "full" to provide a
more accurate description of what happens. There are still a few leftover occurrences of "hard"
in the docs here and there.
> However, "soft" doesn't provide much indication of what happens in that kind of upgrade.
Would "partial" be more correct? If not, is there a good alternative?
> I can go through the docs and fix the language based on whatever you all think makes
sense.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message