db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-6059) Document Derby usage running on Java 8 JEP 161 Compact Profiles
Date Fri, 08 Feb 2013 21:07:12 GMT

    [ https://issues.apache.org/jira/browse/DERBY-6059?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13574823#comment-13574823
] 

Kim Haase commented on DERBY-6059:
----------------------------------

We seem to be inconsistent about what our DataSource implementations support.

In the updated Javadoc -- for example, https://builds.apache.org/job/Derby-trunk/lastSuccessfulBuild/artifact/trunk/javadoc/engine/org/apache/derby/jdbc/ClientDataSource40.html
-- it says that plain ClientDataSource is suitable for Java SE 6 (JDBC 4.0) and below, and
that ClientDataSource40 is suitable for Java SE 7 (JDBC 4.1) and above. However, in the Reference
Manual (http://db.apache.org/derby/docs/10.9/ref/rrefjdbc4_0dataSource.html and http://db.apache.org/derby/docs/10.9/ref/rrefapi1003363.html,
for example) we have been saying that the plain version (ClientDataSource etc.) is for Java
SE 5 (JDBC 3) and that ClientDataSource40 is suitable for Java SE 6 (JDBC 4.0) and higher.
This is also what we said in the Javadoc at 10.9: http://db.apache.org/derby/docs/10.9/publishedapi/jdbc4/org/apache/derby/jdbc/ClientDataSource40.html

On the face of it it would seem as if a class with the "40" suffix should be meant for JDBC
4.0 and above, which is what we have been saying, and that the latest Javadoc needs fixing.
Is this so? Thanks!
                
> Document Derby usage running on Java 8 JEP 161 Compact Profiles
> ---------------------------------------------------------------
>
>                 Key: DERBY-6059
>                 URL: https://issues.apache.org/jira/browse/DERBY-6059
>             Project: Derby
>          Issue Type: Improvement
>          Components: Documentation
>            Reporter: Dag H. Wanvik
>            Assignee: Kim Haase
>             Fix For: 10.10.0.0
>
>         Attachments: javadoc-snapshot.pdf
>
>
> Document that Derby can run even under constrained Java runtime as planned for Java 8
Compact Profiles 2 and 3 (not 1, the smallest runtime, since it has no JDBC). Cf work in DERBY-5955
which made Derby run gracefully even when some normal Java runtime packages are missing, notably
JNDI and JMX.
> That work introduced six new data sources which have reduced functionality compared with
the corresponding ones for full Java SE, in that there is no JNDI support. The six new data
sources are for the client driver:
> Client/server data sources for use with Java 8 Compact Profile 2 and above:
>     BasicClientDataSource40 - Data source
>     BasicClientConnectionPoolDataSource40 - Connection pooling data source
>     BasicClientXADataSource40 - XA data source 
> Embedded data sources for use with Java 8 Compact Profile 2 and above:
>     BasicEmbeddedDataSource40 - Data source
>     BasicEmbeddedConnectionPoolSource40 - Connection pooling data source
>     BasicEmbeddedXASource40 - XA data source 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message