db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Myrna van Lunteren <m.v.lunte...@gmail.com>
Subject Re: Do you have a core and UI plugin version that work with Eclipse Juno?
Date Fri, 04 Jan 2013 19:45:12 GMT
On Fri, Jan 4, 2013 at 9:33 AM, Canh Vu <canhminhvu@gmail.com> wrote:
> Dear developers,
>
> I am working on a project in Eclipse Juno and using derby_core_plugin_10.8.2
> and derby_ui_doc_plugin_1.1.3 to set up derby database.
> However, this derby version (seems the latest one) is NOT working with
> Eclipse Juno.
>
> Error:
>
> Error adding Derby jars to the project:
> org.eclipse.ui.internal.WorkbenchWindow cannot be cast to
> org.eclipse.jface.window.ApplicationWindow
>
>
> Do you have a work-around or a solution for this problem?
>
> Thanks,
> Canh

Hi,

I'm not familiar with that error. Last version I worked with was
Eclipse Indigo.

I'm sorry to be the bearer of bad news for you - the community has
decided to no longer create the plugins (with versions after 10.8.2)
because our charters specify we are not creating GUI interfaces or
IDEs.
Similarly there will be no effort to support Eclipse Juno.

You should be able to unzip the lib distribution in to a suitable
location and add the derby jars manually to your project's classpath
using the project's properties, and create suitable 'Run'
configurations for what you need (ij, NetworkServer start/stop,
sysinfo).
I cannot give you specific steps as I've not (yet) worked with Juno.

HTH,
Myrna

Mime
View raw message