db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5938) Documentation says Derby works with Java 1.4.2
Date Fri, 12 Oct 2012 14:13:03 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5938?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13475007#comment-13475007
] 

Kim Haase commented on DERBY-5938:
----------------------------------

It does seem odd that it's a VARCHAR(32672) when the code is a CHAR(1) or, in the foreseeable
future, CHAR(2). But figuring out why, and how to fix it, is beyond me. 

Simple character codes are common in the system tables. The current doc for this one is clearer
on the reason, showing that we got stuck with two codes for 1.4 for some reason (4 for 1.4.0
and 1.4.1, 5 for 1.4.2) so the numbering went out of sync. But if we remove the part about
1.4 I don't think we should make up a reason for the oddity.

I guess I will file a JIRA on the JVMInfo update, since early access versions of JDK 8 are
available. Whether to go beyond that and make further fixes to the table I'll leave to others.
                
> Documentation says Derby works with Java 1.4.2
> ----------------------------------------------
>
>                 Key: DERBY-5938
>                 URL: https://issues.apache.org/jira/browse/DERBY-5938
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.10.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Kim Haase
>
> The documentation says that Derby works with Java 1.4.2. This is not true on trunk, as
support for Java 1.4.2 is removed for Derby 10.10. A quick search came up with these places
that need change:
> * Getting started guide:
> http://db.apache.org/derby/docs/dev/getstart/tgssetupverify.html
> http://db.apache.org/derby/docs/dev/getstart/cgstutorialintro.html
> http://db.apache.org/derby/docs/dev/getstart/tgssetupjavaenvir.html
> http://db.apache.org/derby/docs/dev/getstart/cgsintsr.html
> Need to change the above topics to say that you need JDK 1.5 or later installed to run
the examples.
> * Developer's guide:
> http://db.apache.org/derby/docs/dev/devguide/rdevconcepts713.html
> The cell for the combination Multi-User/Embedded mentions potential multi-boot problems
in pre-1.4 JVMs. Derby doesn't run on pre-1.4 JVMs anymore (and hasn't done for a long time).
However, the multi-boot problem is present on CDC/FP 1.1, which is still a supported platform,
so maybe we should change "pre-1.4" to "J2ME" (or however we usually refer to that platform
in the docs).
> * Admin guide:
> http://db.apache.org/derby/docs/dev/adminguide/cadminappsthenetworkserverandjvms.html
> Should say that the server is compatible with Java 5 and above.
> * Tools guide:
> http://db.apache.org/derby/docs/dev/tools/ctools1003034.html
> Although it's technically correct that the tools do run on Java 1.4, it's not possible
to access a Derby database with them on Java 1.4 in any supported way (unsupported way: use
derbytools.jar from 10.10 and derby.jar from 10.9). So we should change this topic to say
Java 5 and above, perhaps also mentioning CDC/Foundation Profile 1.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message