db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-5938) Documentation says Derby works with Java 1.4.2
Date Fri, 12 Oct 2012 14:57:03 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5938?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kim Haase updated DERBY-5938:
-----------------------------

    Attachment: DERBY-5938.zip
                DERBY-5938.stat
                DERBY-5938.diff

Attaching DERBY-5938.diff, DERBY-5938.stat, and DERBY-5938.zip, with changes as follows:

M       build.xml
M       docs.properties
M       src/devguide/rdevresman79556.dita
M       src/devguide/rdevprocsqle.dita
M       src/devguide/cdevstart18978.dita
M       src/devguide/cdevdvlp40653.dita
M       src/devguide/cdevstandardsxml.dita
M       src/devguide/rdevconcepts713.dita
M       src/devguide/derbydev.ditamap
M       src/getstart/tgssetupjavaenvir.dita
M       src/getstart/cgsintsr.dita
M       src/getstart/tgssetupverify.dita
M       src/getstart/cgstutorialintro.dita
M       src/tools/ctools1003034.dita
M       src/adminguide/cadminappsthenetworkserverandjvms.dita
M       src/adminguide/cadminapps811695.dita
M       src/adminguide/derbyadmin.ditamap
M       src/ref/rrefsysxplain_statements.dita
M       src/ref/rrefattribderegister.dita
M       src/ref/rrefjavsqlprst.dita
M       src/ref/rrefapi1003363.dita

I created a property for the minimum JDK and used it where appropriate. I didn't use it where
a specific contrast between SE 5 and SE 6 is made, because if/when the minimum supported JDK
becomes SE 6, those topics will need to be rewritten.

I found occurrences of "JDK 1.4" as well as "JDK 1.4.2", and also some occurrences of "JDK
5 and earlier". 

I removed mentions of specific versions where a feature is now supported on all current versions.

For the multi-boot topic I used the language that is used elsewhere in the Developer's Guide
to talk about the CDC platforms. 

I used this opportunity to fix a couple of trademarked terms here and there.

Please let me know what additional fixes are needed, if any.


                
> Documentation says Derby works with Java 1.4.2
> ----------------------------------------------
>
>                 Key: DERBY-5938
>                 URL: https://issues.apache.org/jira/browse/DERBY-5938
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.10.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Kim Haase
>         Attachments: DERBY-5938.diff, DERBY-5938.stat, DERBY-5938.zip
>
>
> The documentation says that Derby works with Java 1.4.2. This is not true on trunk, as
support for Java 1.4.2 is removed for Derby 10.10. A quick search came up with these places
that need change:
> * Getting started guide:
> http://db.apache.org/derby/docs/dev/getstart/tgssetupverify.html
> http://db.apache.org/derby/docs/dev/getstart/cgstutorialintro.html
> http://db.apache.org/derby/docs/dev/getstart/tgssetupjavaenvir.html
> http://db.apache.org/derby/docs/dev/getstart/cgsintsr.html
> Need to change the above topics to say that you need JDK 1.5 or later installed to run
the examples.
> * Developer's guide:
> http://db.apache.org/derby/docs/dev/devguide/rdevconcepts713.html
> The cell for the combination Multi-User/Embedded mentions potential multi-boot problems
in pre-1.4 JVMs. Derby doesn't run on pre-1.4 JVMs anymore (and hasn't done for a long time).
However, the multi-boot problem is present on CDC/FP 1.1, which is still a supported platform,
so maybe we should change "pre-1.4" to "J2ME" (or however we usually refer to that platform
in the docs).
> * Admin guide:
> http://db.apache.org/derby/docs/dev/adminguide/cadminappsthenetworkserverandjvms.html
> Should say that the server is compatible with Java 5 and above.
> * Tools guide:
> http://db.apache.org/derby/docs/dev/tools/ctools1003034.html
> Although it's technically correct that the tools do run on Java 1.4, it's not possible
to access a Derby database with them on Java 1.4 in any supported way (unsupported way: use
derbytools.jar from 10.10 and derby.jar from 10.9). So we should change this topic to say
Java 5 and above, perhaps also mentioning CDC/Foundation Profile 1.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message