db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DERBY-5938) Documentation says Derby works with Java 1.4.2
Date Wed, 26 Sep 2012 10:12:08 GMT
Knut Anders Hatlen created DERBY-5938:

             Summary: Documentation says Derby works with Java 1.4.2
                 Key: DERBY-5938
                 URL: https://issues.apache.org/jira/browse/DERBY-5938
             Project: Derby
          Issue Type: Bug
          Components: Documentation
    Affects Versions:
            Reporter: Knut Anders Hatlen

The documentation says that Derby works with Java 1.4.2. This is not true on trunk, as support
for Java 1.4.2 is removed for Derby 10.10. A quick search came up with these places that need

* Getting started guide:


Need to change the above topics to say that you need JDK 1.5 or later installed to run the

* Developer's guide:


The cell for the combination Multi-User/Embedded mentions potential multi-boot problems in
pre-1.4 JVMs. Derby doesn't run on pre-1.4 JVMs anymore (and hasn't done for a long time).
However, the multi-boot problem is present on CDC/FP 1.1, which is still a supported platform,
so maybe we should change "pre-1.4" to "J2ME" (or however we usually refer to that platform
in the docs).

* Admin guide:


Should say that the server is compatible with Java 5 and above.

* Tools guide:


Although it's technically correct that the tools do run on Java 1.4, it's not possible to
access a Derby database with them on Java 1.4 in any supported way (unsupported way: use derbytools.jar
from 10.10 and derby.jar from 10.9). So we should change this topic to say Java 5 and above,
perhaps also mentioning CDC/Foundation Profile 1.1.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message