db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5938) Documentation says Derby works with Java 1.4.2
Date Wed, 26 Sep 2012 13:19:08 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5938?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13463790#comment-13463790
] 

Kim Haase commented on DERBY-5938:
----------------------------------

Thanks for tracking all those occurrences of 1.4 down, Knut. I'll make sure to catch any others.

Maybe we need another docs.properties variable, something like min.jdk, so that any needed
backporting wouldn't create inaccurate information. I think we'd have to add another filter
to the filterset in the preprocess-copy target of the build.xml file as well. Does this make
sense? It might simplify matters going forward.
                
> Documentation says Derby works with Java 1.4.2
> ----------------------------------------------
>
>                 Key: DERBY-5938
>                 URL: https://issues.apache.org/jira/browse/DERBY-5938
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.10.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Kim Haase
>
> The documentation says that Derby works with Java 1.4.2. This is not true on trunk, as
support for Java 1.4.2 is removed for Derby 10.10. A quick search came up with these places
that need change:
> * Getting started guide:
> http://db.apache.org/derby/docs/dev/getstart/tgssetupverify.html
> http://db.apache.org/derby/docs/dev/getstart/cgstutorialintro.html
> http://db.apache.org/derby/docs/dev/getstart/tgssetupjavaenvir.html
> http://db.apache.org/derby/docs/dev/getstart/cgsintsr.html
> Need to change the above topics to say that you need JDK 1.5 or later installed to run
the examples.
> * Developer's guide:
> http://db.apache.org/derby/docs/dev/devguide/rdevconcepts713.html
> The cell for the combination Multi-User/Embedded mentions potential multi-boot problems
in pre-1.4 JVMs. Derby doesn't run on pre-1.4 JVMs anymore (and hasn't done for a long time).
However, the multi-boot problem is present on CDC/FP 1.1, which is still a supported platform,
so maybe we should change "pre-1.4" to "J2ME" (or however we usually refer to that platform
in the docs).
> * Admin guide:
> http://db.apache.org/derby/docs/dev/adminguide/cadminappsthenetworkserverandjvms.html
> Should say that the server is compatible with Java 5 and above.
> * Tools guide:
> http://db.apache.org/derby/docs/dev/tools/ctools1003034.html
> Although it's technically correct that the tools do run on Java 1.4, it's not possible
to access a Derby database with them on Java 1.4 in any supported way (unsupported way: use
derbytools.jar from 10.10 and derby.jar from 10.9). So we should change this topic to say
Java 5 and above, perhaps also mentioning CDC/Foundation Profile 1.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message