db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5920) Network Server should accept DRDA connections from drivers with the StarQuest PRDID "SIG"
Date Mon, 17 Sep 2012 13:54:08 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5920?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13457025#comment-13457025
] 

Knut Anders Hatlen commented on DERBY-5920:
-------------------------------------------

I don't think we maintain a list of protocol extensions. However, in the cases where we've
extended the protocol, the server should already be checking that it talks to a client that
understands the extension. That is, it checks that the PRDID is DNC and that the client version
is recent enough to support the extension. So it should not use the extensions when talking
to a non-DNC client. The supports* methods in org.apache.derby.impl.drda.AppRequester would
be a good starting point for exploring which extensions exist.
                
> Network Server should accept DRDA connections from drivers with the StarQuest PRDID "SIG"
> -----------------------------------------------------------------------------------------
>
>                 Key: DERBY-5920
>                 URL: https://issues.apache.org/jira/browse/DERBY-5920
>             Project: Derby
>          Issue Type: Improvement
>          Components: Network Server
>    Affects Versions: 10.9.1.0
>         Environment: Any
>            Reporter: David Brown
>              Labels: DRDA, SIG, StarQuest, StarSQL, client, network
>
> Background - Refer to DERBY-5565
> "Derby Network Server has been changed to reject client connections from clients that
are not Derby Network Client (Those that do not send PRDID starting with DNC).
> Rationale for Change: There are currently no known supported network clients for Derby
Network Server other than Derby Network Client."
> This is incorrect - StarQuest Ventures has a shipping DRDA-compliant network client "StarSQL
for Java" that has supported Derby since August 2008. It is listed at http://wiki.apache.org/db-derby/UsesOfDerby.
> This change means that we can now only use an older version of Derby until our PRDID
is added.
> Our PRDID is SIG - see http://publib.boulder.ibm.com/infocenter/iseries/v7r1m0/index.jsp?topic=%2Fddp%2Frbal1exitpgms.htm
for a list of DRDA PRDID's.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message