db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-4082) Cannot shutdown Network Server on IPv6 machine 'host: loopback6.xxx.xxx.xxx.com is not local to the server'
Date Wed, 26 Sep 2012 21:43:09 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4082?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kathey Marsden updated DERBY-4082:
----------------------------------

    Issue & fix info:   (was: High Value Fix)

Unmarking High Value Fix as presumably the issue can be worked around with a custom policy
file which is recommended when allowing external connections with -h  anyway.   Also not sure
if this  is just a machine configuration issue.


                
> Cannot shutdown Network Server on IPv6 machine 'host: loopback6.xxx.xxx.xxx.com  is not
local to the server'
> ------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-4082
>                 URL: https://issues.apache.org/jira/browse/DERBY-4082
>             Project: Derby
>          Issue Type: Bug
>          Components: Network Server
>    Affects Versions: 10.5.1.1
>            Reporter: Kathey Marsden
>              Labels: derby_triage10_9
>
> I started network server on an IPv6 machine with 
> java org.apache.derby.drda.NetworkServerControl start  -h maxilla-v6.xxx.xxx.xxx.com
> I was able to then connect ok with ij and ping the server but when I try to shutdown

> java org.apache.derby.drda.NetworkServerControl shutdown  -h maxilla-v6.xxx.xxx.xxx.com
> I get:
> 2009-03-04 22:46:13.666 GMT : host: loopback6.xxx.xxx.xxx.com is not local to the server
running on maxilla-v6.xxx.xxx.xxx.com. so cannot be used for NetworkServerControl commands
> (domain names xx'ed out)
> I don't know if this is something particular to this machine or a problem with all IPv6
machines, but it looks like a bug.   This particular machine has an IPv4 address as well as
IPv6 and maybe that has something to do with it. Apparently there is a problem with our collection
of local IP addresses on IPv6.  This was with IBM 1.6.
> Does anyone use network server on an IPv6 successfully, assuming you ever have tried
taking it down #:)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message