db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5905) Derby html documentation doesn't render properly and prints garbage on Internet Explorer
Date Tue, 21 Aug 2012 18:37:38 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13438933#comment-13438933
] 

Kim Haase commented on DERBY-5905:
----------------------------------

It seems as if something weird is going on, possibly as an interaction between DERBY-5905
and DERBY-5359. 

Before the changes for these two issues, the html tag for the output looked like this (see
the current 10.8 docs on the website for examples):

<html lang="en-us" xml:lang="en-us">

Now, after applying the patches, when I run "ant getstart" I get the following warnings:

     [xslt] /export/home/chaase/derbydoc/trunk/DITA-OT1.1.2.1/xsl/map2htmtoc.xsl:9:18: Warning!
Cannot add attribute lang after child nodes or before an element is produced.  Attribute will
be ignored.

     [xslt] /export/home/chaase/derbydoc/trunk/DITA-OT1.1.2.1/xsl/dita2xhtml.xsl:8:18: Warning!
Cannot add attribute lang after child nodes or before an element is produced.  Attribute will
be ignored.

So the html tag in an output file that I generate now looks like this:

<html xmlns="http://www.w3.org/1999/xhtml">

On the web site itself, however, for the trunk and 10.9 docs the tag is just

<html>

I'm completely befuddled by this, so I'm just reporting what I am seeing. But we need the
lang attributes for accessibility, in addition to the xmlns attribute.
                
> Derby html documentation doesn't render properly and prints garbage on Internet Explorer
> ----------------------------------------------------------------------------------------
>
>                 Key: DERBY-5905
>                 URL: https://issues.apache.org/jira/browse/DERBY-5905
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.8.2.2, 10.9.1.0, 10.10.0.0
>            Reporter: Kathey Marsden
>         Attachments: d5905-1a-move-comments.diff, screenshot-1.jpg
>
>
> There have been reports that DERBY html documentation does not render on Internet Explorer
8 and 9.
> Kristian reports on IE8
> Just tried with IE8, and with the Getting Started manual I get this when I view the source:
> """
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <HTML><HEAD>
> <META content="text/html; charset=utf-8" http-equiv=Content-Type></HEAD>
> <BODY></BODY></HTML>
> <snipped garbage as to not put it in jira>
> Not sure how that last line will turn out in your email clients, but it is indeed garbage
and you can see that the body-tag is empty. Nothing is rendered in the browser. We are using
frames though - that's not exactly state-of-the-art... We are also using the wrong DOCTYPE.
I'm suspecting that the HTML is invalid too, but haven't checked. 
> On IE9 I had heard that the reference HTML manual prints garbage.
> http://db.apache.org/derby/manuals/index.html#latest

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message