db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (DERBY-5424) On z/OS testConnectWrongSubprotocolWithSystemProperty(org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest)junit.framework.Asserti ailedError
Date Wed, 13 Jun 2012 17:23:43 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5424?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kathey Marsden reassigned DERBY-5424:
-------------------------------------

    Assignee: Kathey Marsden
    
> On z/OS testConnectWrongSubprotocolWithSystemProperty(org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest)junit.framework.Asserti
ailedError
> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-5424
>                 URL: https://issues.apache.org/jira/browse/DERBY-5424
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.8.2.2
>         Environment: ava version "1.6.0"
> ava(TM) SE Runtime Environment (build pmz6460sr9fp1-20110303_01(SR9 FP1))
> BM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 z/OS s390x-64 jvmmz6460sr9-20110203_74623 (JIT
enabled, AOT enabled)
> 9VM - 20110203_074623
> IT  - r9_20101028_17488ifx3
> C   - 20101027_AA)
> CL  - 20110203_01
>            Reporter: Kathey Marsden
>            Assignee: Kathey Marsden
>            Priority: Minor
>
> With the release candidate  10.8.2.1 - (1170221) I saw the following two failures on
z/OS in testConnectWrongSubprotoctestolWithoutSystemProperty
> There were 2 failures:
> 1) testConnectWrongSubprotocolWithSystemProperty(org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest)junit.framework.Asserti
> onFailedError
>         at org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest.checkConnectWrongSubprotocol(ConnectWrongSubprotocolTest.java
> :82)
>         at org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest.testConnectWrongSubprotocolWithSystemProperty(ConnectWrongSub
> protocolTest.java:68)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
>         at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
>         at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
>         at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
>         at junit.extensions.TestSetup.run(TestSetup.java:16)
> 2) testConnectWrongSubprotoctestolWithoutSystemProperty(org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest)junit.framework.
> AssertionFailedError
>         at org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest.checkConnectWrongSubprotocol(ConnectWrongSubprotocolTest.java
> :82)
>         at org.apache.derbyTesting.functionTests.tests.tools.ConnectWrongSubprotocolTest.testConnectWrongSubprotoctestolWithoutSystemProperty(ConnectW
> rongSubprotocolTest.java:76)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
>         at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
>         at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
>         at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
>         at junit.extensions.TestSetup.run(TestSetup.java:16)
> FAILURES!!!
> Tests run: 13984,  Failures: 2,  Errors: 0
> The test is newly converted with DERBY-5084 so not likely a regression, but probably
more likely an encoding issue related to this test:
>        String ijResult = runIjScript(ijScript, useSystemProperties);       
>                 assertTrue(ijResult.indexOf("08001") > -1);

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message