db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-5746) Minor refactoring of DataDictionaryImpl.getSetAutoincrementValue
Date Wed, 16 May 2012 04:12:18 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5746?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Kristian Waagan updated DERBY-5746:

    Attachment: derby-5746-2a-assert_on_fetch.diff

Attaching patch 2a, which adds asserts in the two cases where the return value from ConglomerateController.fetch
are ignored.

Regression tests passed, read for review.
> Minor refactoring of DataDictionaryImpl.getSetAutoincrementValue
> ----------------------------------------------------------------
>                 Key: DERBY-5746
>                 URL: https://issues.apache.org/jira/browse/DERBY-5746
>             Project: Derby
>          Issue Type: Improvement
>          Components: SQL
>    Affects Versions:
>            Reporter: Kristian Waagan
>            Assignee: Kristian Waagan
>            Priority: Minor
>         Attachments: derby-5746-1a-minor_refactoring.diff, derby-5746-2a-assert_on_fetch.diff
> DataDictionaryImpl.getSetAutoincrementValue contains an unused local variable, and while
looking at removing it I saw that some of the statements in the method could be reordered
to reduce object creation and improve readability.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message