db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Primer for Derby build, was: Fwd: Junit 3.8.2 download?
Date Mon, 30 Jan 2012 13:45:04 GMT
Hi Bryan,

These sound like good changes to me. A couple comments inline...

On 1/28/12 9:01 AM, Bryan Pendleton wrote:
> Following-up my own message, I see that there is already a junit.jar
> in the svn distribution.
>
> So I guess I don't need to worry about downloading junit 3.8.2.
>
> A couple notes about the building source docs:
>
> 1) http://db.apache.org/derby/dev/derby_source.html, in the section
> "Software required to build Derby", seems to say that I need Java JDK 1.5, but
> I appear to be successful using JDK 1.6, so perhaps that should say
> "Java 5 OR Java 6"?
Or Java 7. How about "any JDK at level Java 5 or higher"?
> 2) http://svn.apache.org/viewvc/db/derby/code/trunk/BUILDING.html, should
> we remove "You can get JUnit 3.8.2 here. ", since that no longer seems
> to be correct?
That sounds right to me. The junit jar is not in our subversion 
repository but is downloaded by the build. Kristian's response to your 
other message shows us where to get the jar if the build messes up: 
http://repo1.maven.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar
> 3) http://svn.apache.org/viewvc/db/derby/code/trunk/java/testing/README.htm?revision=1102688&view=co,
> should we remove the sub-paragraph in "set $CLASSPATH to include the
> following jars: "
> which talks about "db2jcc.jar and db2jcc_license_c.jar" -- we no
> longer use those jars, right?
Maybe Kathey or Myrna can verify this.

Thanks,
-Rick

> thanks,
>
> bryan
>


Mime
View raw message