db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Matrigali (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5542) Remove checks for Java version being greater than or equal to 1.4
Date Thu, 15 Dec 2011 18:14:30 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13170381#comment-13170381
] 

Mike Matrigali commented on DERBY-5542:
---------------------------------------

Do you happen to know what now happens if you try to run 10.8 with a pre-jdk14 jvm.  It would
be nice if you got some reasonable error or warning vs. some wierd error now that the old
code path is gone.  Doing this in one place at boot is probably reasonable cost vs the multiple
checks that you are going after.
                
> Remove checks for Java version being greater than or equal to 1.4
> -----------------------------------------------------------------
>
>                 Key: DERBY-5542
>                 URL: https://issues.apache.org/jira/browse/DERBY-5542
>             Project: Derby
>          Issue Type: Improvement
>          Components: Miscellaneous
>    Affects Versions: 10.9.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Knut Anders Hatlen
>            Priority: Trivial
>         Attachments: d5542.diff
>
>
> The code contains some checks for JVMInfo.JDK_ID >= JVMInfo.J2SE_14. That condition
evaluates to true on all currently supported platforms (including on CDC/FP), so the checks
can be removed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message