db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5300) Change derby.tests.trace to print the class as well as fixture name
Date Thu, 13 Oct 2011 13:40:12 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5300?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13126578#comment-13126578
] 

Kristian Waagan commented on DERBY-5300:
----------------------------------------

Thanks, Jayaram.

The newest patch looks ok to me - it does the right things.

Some possible improvements:
 o there are no method JavaDoc
 o is the formatSubString a good method name for this method?
   To me it seems the method is specifically targeted at formatting test class names.
 o COMMON_[FUNCTION]TEST_PREFIX could be constants (private static final)
 o since you use startsWith and want the rest of the string,
      mainString.substring(mainString.indexOf(COMMON_FUNCTIONTEST_PREFIX)+COMMON_FUNCTIONTEST_PREFIX.length(),mainString.length());
    could be simplified to
      mainString.substring(COMMON_FUNCTIONTEST_PREFIX.length())
 o inconsistent use of tabs and spaces for indentation
 o mix of tabs and spaces for indentation (on the same line)
 o inconsistent placement of braces in formatSubString (either one is fine, but it's usually
easier to read code where the placement is consistent)

It's up to you which of the suggestions, if any, you want to address :) In my opinion, they
would increase the code quality. Feel free to ask questions if you have any.


Regards,
                
> Change derby.tests.trace to print the class as well as fixture name
> -------------------------------------------------------------------
>
>                 Key: DERBY-5300
>                 URL: https://issues.apache.org/jira/browse/DERBY-5300
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>    Affects Versions: 10.9.0.0
>            Reporter: Kathey Marsden
>            Assignee: Jayaram Subramanian
>            Priority: Trivial
>         Attachments: classinfixture-Oct132011.diff, classinfixture-stat-oct132011.out,
classinfixture_Aug182011.txt, derby-5300-1a-print_jdbc_client.diff, svnstat-classinfixture.txt
>
>
> I was thinking it would be good for the test output with -Dderby.tests.trace=true to
have the class name as well as the fixture as I think if I had a nickel  for every time I
grepped for a fixture name to find out what class it is in, I would have a pretty big piggy
bank.
> It could print the full class name, like this:
> org.apache.derbyTesting.functionTests.tests.lang.SimpleTest.testBasicOperations used
844 ms .
> or strip off the org.apache.derbyTesting.functionTests for less output like:
> tests.lang.SimpleTest.testBugFixes used 6265 ms .
> Any preferences?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message