db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: weme failures with a sane build
Date Thu, 25 Aug 2011 12:51:16 GMT
Thanks, Knut. RestrictedVTITest runs cleanly for me on phoneME after 
disabling the security manager as Kathey indicated. The results you are 
seeing are consistent with what Kathey saw before I disabled that test 
case. I don't expect test_11_5369_5370 to run on small devices.

The issue with sane and insane builds affects another test, 
SequenceGeneratorTest. I have run that test on phoneME (disabling the 
SecurityManager) and I see a version of what Kathey is seeing. However, 
the problem suspends the phoneME VM so the problem plays out differently 
on that platform.

Thanks,
-Rick



On 8/25/11 12:30 AM, Knut Anders Hatlen wrote:
> Rick Hillegas<rick.hillegas@oracle.com>  writes:
>
>> On 8/23/11 1:02 PM, Kathey Marsden wrote:
>>> On 8/23/2011 9:15 AM, Rick Hillegas wrote:
>>>> Hi Kathey,
>>>>
>>>> I disabled the new test on JSR169. It uses a table function which
>>>> implements the JDBC 3.0 ResultSet interface. That causes
>>>> ClassNotFoundExceptions on JSR169. Let me know if you are still
>>>> seeing problems with that test.
>>>>
>>> Thanks for taking care of that.
>>>
>>>> The other problem I have not seen before. I run the tests against
>>>> sane jars. Can you reproduce the problem with sane jars on Java 5,
>>>> 6, or 7?
>>>>
>>> I think it is specific to weme and specific to sane builds so may
>>> have been around for some times since the nightlies run with the
>>> insane build.  I filed DERBY-5389. It would be interesting to see if
>>> phoneME has a the same issue with a sane build
>> Yes. It would be great if someone who has a working phoneME
>> environment could try this out. I tried yesterday on my phoneME
>> environment which runs on top of Ubuntu under VirtualBox on my Mac.
>> The test doesn't even run for me in that environment--I get security
>> violations at startup. I could swear that I used to be able to run
>> JUnit tests in that environment. It will take some effort to figure
>> out what is broken.
> Here's what I see in phoneME when I re-enable the test case, *both* with
> sane and insane builds:
>
> 1) test_11_5369_5370(org.apache.derbyTesting.functionTests.tests.lang.RestrictedVTITest)java.sql.SQLException:
Java exception: 'java.sql.Array: java.lang.NoClassDefFoundError'.
> 	at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
> 	at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
> 	at org.apache.derby.impl.jdbc.EmbedPreparedStatement169.<init>(Unknown Source)
> 	at org.apache.derby.jdbc.Driver169.newEmbedPreparedStatement(Unknown Source)
> 	at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
> 	at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
> 	at org.apache.derbyTesting.functionTests.tests.lang.GeneratedColumnsHelper.chattyPrepare(Unknown
Source)
> 	at org.apache.derbyTesting.functionTests.tests.lang.GeneratedColumnsHelper.assertResults(Unknown
Source)
> 	at org.apache.derbyTesting.functionTests.tests.lang.RestrictedVTITest.vet5370positive(Unknown
Source)
> 	at org.apache.derbyTesting.functionTests.tests.lang.RestrictedVTITest.test_11_5369_5370(Unknown
Source)
> 	at org.apache.derbyTesting.junit.BaseTestCase.runBare(Unknown Source)
> 	at junit.extensions.TestDecorator.basicRun(Unknown Source)
> 	at junit.extensions.TestSetup$1.protect(Unknown Source)
> 	at junit.extensions.TestSetup.run(Unknown Source)
> 	at org.apache.derbyTesting.junit.BaseTestSetup.run(Unknown Source)
> 	at sun.misc.CVM.runMain(Unknown Source)
> Caused by: java.lang.NoClassDefFoundError: java.sql.Array
> 	at java.lang.Class.getMethods0(Native Method)
> 	at java.lang.Class.getMethods(Unknown Source)
> 	at org.apache.derby.iapi.services.loader.ClassInspector.findPublicMethod(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.MethodCallNode.resolveMethodCall(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.StaticMethodCallNode.bindExpression(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.FromVTI.bindVTITables(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.FromList.bindTables(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.SelectNode.bindNonVTITables(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.DMLStatementNode.bindTables(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.DMLStatementNode.bind(Unknown Source)
> 	at org.apache.derby.impl.sql.compile.CursorNode.bindStatement(Unknown Source)
> 	at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
> 	at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
> 	at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown
Source)
> 	... 27 more
>


Mime
View raw message