db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: Sunsetting support for Derby on JVM 1.4
Date Fri, 01 Jul 2011 18:57:56 GMT
Thanks to everyone for the discussion so far. Here is a revised 
statement of what we would like to do:

o The 10.8 family of releases will be the last family supporting JVM 1.4.

o Starting with 10.9, Derby will no longer support JVM 1.4.

o This means that 10.9 will not be tested on JVM 1.4.

o This also means that Java 5 language features can be used in client 
code, network server code, and in the embedded JDBC classes which are 
not loaded when running at the JSR 169 level.

o Release notes for the 10.9 family will claim that we support the 
following JDBC levels on the following platforms:

    - JSR 169 on CDC/FP 1.1
    - JDBC 3.0 on Java 5
    - JDBC 4.1 on Java 6 and Java 7

How does this sound?

Thanks,
-Rick


Mime
View raw message