db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DERBY-5262) Running JUnit tests with Java 1.4.2 fails if the package private tests are on the classpath
Date Tue, 07 Jun 2011 04:49:59 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5262?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kristian Waagan resolved DERBY-5262.
------------------------------------

          Resolution: Fixed
       Fix Version/s: 10.9.0.0
                      10.8.1.4
    Issue & fix info:   (was: [Patch Available])

The regression tests ran cleanly.
Committed to trunk with revision 1132860 and back-ported to 10.8 with revision 1132861.

> Running JUnit tests with Java 1.4.2 fails if the package private tests are on the classpath
> -------------------------------------------------------------------------------------------
>
>                 Key: DERBY-5262
>                 URL: https://issues.apache.org/jira/browse/DERBY-5262
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.9.0.0
>            Reporter: Kristian Waagan
>            Assignee: Kristian Waagan
>            Priority: Minor
>             Fix For: 10.8.1.4, 10.9.0.0
>
>         Attachments: derby-5262-1a-secmansetup_check_class_version.diff
>
>
> Running tests with Java 1.4.2 with the package private tests (pptesting) on the classpath
results in:
> Failed to invoke suite():java.lang.UnsupportedClassVersionError: org/apache/derby/PackagePrivateTestSuite
(Unsupported major.minor version 49.0)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message