db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-5286) Remove or update tools/ide/netbeans directory
Date Mon, 20 Jun 2011 10:59:47 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5286?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Knut Anders Hatlen updated DERBY-5286:
--------------------------------------

    Attachment: update-project.diff

Here's an attempt to fix the issue by switching from two projects to one and update the new
project to be more usable.

First, copy the 6.0 version of the project to a location without a version number:

svn cp tools/ide/netbeans/6.0/nbproject tools/ide/netbeans

Then remove the version-specific projects:

svn rm tools/ide/netbeans/5.5 tools/ide/netbeans/6.0

Finally, update the project using the attached patch (update-project.diff). The patch makes
the following changes to the project definition:

1) Adjust the relative path to the project directory to account for the nbproject directory
being moved up one level.

2) Modify classpath:

  - Remove tools/java/xercesImpl.jar since it's no longer in the repository.

  - Change reference to ant.jar to ${ant.core.lib} so that it works without copying ant.jar
to tools/java.

  - Remove the classes directory since it's not needed and causes duplicate entries in the
Go to type dialogue window.

3) Change source level from 1.4 to 1.5 to prevent error markers when working on code that
uses generics or other 1.5 language features. 

4) Add project-specific formatting so that you don't need to change the global formatting
settings to get the correct tab size for Derby code.

> Remove or update tools/ide/netbeans directory
> ---------------------------------------------
>
>                 Key: DERBY-5286
>                 URL: https://issues.apache.org/jira/browse/DERBY-5286
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.9.0.0
>            Reporter: Knut Anders Hatlen
>            Priority: Minor
>         Attachments: update-project.diff
>
>
> The tools/ide directory contains projects for two versions of NetBeans (5.5 and 6.0).
Since they haven't been updated for newer versions of NetBeans, I suppose it means they aren't
used much. Also, since there are two of them, NetBeans gets confused as to which of the projects
to use, and I have experienced that it often uses a mix of the 5.5 and 6.0 projects for the
open source files, which causes problems for navigation and debugging. The problem with having
multiple NetBeans projects pointing to the same source is described here: http://wiki.netbeans.org/FaqSourceRootOverlap
> To prevent these problems, we should either remove the tools/ide/netbeans directory and
let NetBeans users create their own projects (there a pretty good description on the wiki:
http://wiki.apache.org/db-derby/BuildingDerby#Using_NetBeans_to_Build_Derby ), or provide
an updated project and remove the old ones.
> (The project files aren't really tied to a particular version of NetBeans and can be
opened by newer versions. But the projects still need to be updated to be usable, I think.
For example, they should have project-specific formatting settings (added in NB 6.5, I think)
which set tab size to 4, since setting tab size globally to 4 as you would have to with the
current projects, only works if Derby is the only project you're working on in NetBeans.)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message