db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DERBY-5262) Running JUnit tests with Java 1.4.2 fails if the package private tests are on the classpath
Date Mon, 06 Jun 2011 10:07:58 GMT

     [ https://issues.apache.org/jira/browse/DERBY-5262?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kristian Waagan updated DERBY-5262:
-----------------------------------

    Attachment: derby-5262-1a-secmansetup_check_class_version.diff

Attaching patch 1a, which adds the utility method BaseTestCase.getClassVersionMajor() and
makes use of this method in SecurityManagerSetup to avoid loading a class the JVM can't understand.

I intend to commit this patch as soon as the regression tests finish.
Patch ready for review.

> Running JUnit tests with Java 1.4.2 fails if the package private tests are on the classpath
> -------------------------------------------------------------------------------------------
>
>                 Key: DERBY-5262
>                 URL: https://issues.apache.org/jira/browse/DERBY-5262
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.9.0.0
>            Reporter: Kristian Waagan
>            Assignee: Kristian Waagan
>            Priority: Minor
>         Attachments: derby-5262-1a-secmansetup_check_class_version.diff
>
>
> Running tests with Java 1.4.2 with the package private tests (pptesting) on the classpath
results in:
> Failed to invoke suite():java.lang.UnsupportedClassVersionError: org/apache/derby/PackagePrivateTestSuite
(Unsupported major.minor version 49.0)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message