db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Myrna van Lunteren <m.v.lunte...@gmail.com>
Subject Re: Unknown exception occurred while executing buildjars
Date Mon, 09 May 2011 17:13:41 GMT
On Sun, May 8, 2011 at 3:54 AM, siddharth srivastava
<akssps011@gmail.com> wrote:
> Hi
>
> I checkout the latest source from the trunk and while executing "ant -quiet
> buildjars" I got the following error (though build was successful):
>
>>  [exec] Execute failed: java.io.IOException: Cannot run program
>> "svnversion"
>> : CreateProcess error=2, The system cannot find the file specified
>>  [loadfile] C:\eclipsework\derbytrunk\changenumber.properties doesn't
>> exist
>
> I have never seen this message earlier so was just curious what does this
> mean. I have subversion for windows configured. The system I was using
> earlier for the build (win 7) had the exact build environment that I have
> now (on win XP), but never got this message in earlier builds.
>
> Am I missing something ?
>
> Thanks
>
> --
> Regards
> Siddharth Srivastava
>
>
>

Hi,

At first glance this sounds like a set up problem. Or perhaps a bug in
windows 7 or subversion.
Perhaps you've already done the following, but these are the steps I
can think of:
- Perhaps there's a bug in the subversion version you're using on
windows 7? Run svnversion manually from a command line window.
If you still have the older system available, compare the result in
both systems.
- Create a small .xml that only does the ant call to exec svnversion,
and run that with ant -verbose. (You can copy the relevant section
from <trunk>/build.xml).
- Run the ant with -verbose.
- If the above give no hints, run the full build with the property
printCompilerProperties=true. Perhaps it gives some clue as to what's
happening. Again, if you have the older system still available,
compare.

HTH,
Myrna

Mime
View raw message