db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Houx Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DERBY-5127) Convert madhare.sql to JUnit
Date Tue, 05 Apr 2011 15:20:05 GMT

    [ https://issues.apache.org/jira/browse/DERBY-5127?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13015954#comment-13015954
] 

Houx Zhang commented on DERBY-5127:
-----------------------------------

Just some opinions:

1. Is it better to split the testBasicMadhare() into several functions, and test only one
point in each function? It will make the test more readable and maintainable.

2. Why not use dropTable(String) directly to replace current st.executeUpdate( "drop table
t")  to keep the code clean?


> Convert madhare.sql to JUnit
> ----------------------------
>
>                 Key: DERBY-5127
>                 URL: https://issues.apache.org/jira/browse/DERBY-5127
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>            Reporter: Siddharth Srivastava
>            Assignee: Siddharth Srivastava
>            Priority: Minor
>         Attachments: d5127.diff, derby5127(2).diff, derby5127.diff, derby5127.diff, derby5127.diff,
derby5127.diff
>
>
> Convert madhare.sql to JUnit

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message