db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DERBY-5209) 10.8 upgrade and compatibility testing
Date Thu, 28 Apr 2011 21:35:03 GMT
10.8 upgrade and compatibility testing

                 Key: DERBY-5209
                 URL: https://issues.apache.org/jira/browse/DERBY-5209
             Project: Derby
          Issue Type: Task
          Components: Test
    Affects Versions:
            Reporter: Kathey Marsden

I am doing some upgrade, client/server and  test compatibility testing with 10.8 and am using
this issue for tracking tests and results.  
The first test was to create the system/wombat database with 10.5 and run Suites.All with
10.8 product jars and 10.5 derbyTesting.jar Then I verified I could reconnect with 10.5 and
perform a few operations.

derbyTesting.jar.  Environment for reference is:
export JAVA_HOME="/ibmsvn/ntsoftware/ibm16"
export PATH="$JAVA_HOME/bin:$PATH"
export CLASSPATH="$LIB/derbyrun.jar;$LIB_105/derbyTesting.jar;$TOOLS/junit.jar;

Output attached as test10_8SoftUpgradeFrom10_5.out. There were  Failures: 188,  Errors: 109
which haven't been analyzed yet, but I skimmed them and didn't see anything that looked like
data corruption.

Will also run
10.7 derbyclient.jar, derbyTesting.jar 10.8 other product jars

10.7 derbynet.jar derbyTesting.jar 10.8 other product jars.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message