db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-1048) Include run of junitTests/CompatibilitySuite, or converted compatibility test suite with 10.1/trunk combination into suites.All
Date Mon, 07 Feb 2011 22:33:57 GMT

     [ https://issues.apache.org/jira/browse/DERBY-1048?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Myrna van Lunteren updated DERBY-1048:
--------------------------------------

    Description: 
Incorporate a run of jdbcapi/Compatibility test into derbyall  with the following combinations:

client                server
10.1.1.0           trunk
trunk                10.1.1.0

This can provide some minimal compatibility testing in derbyall against the original client
release.
It requires that the 10.1.1.0 jars be checked in.  I will file a separate issue for this.
Rick is assigned to the top level issue to integrate testing procedures.   He wrote the test
but there was concern that we actually not adding any coverage for compatibility because it
only runs with trunk server/ trunk client.

Adding this combination was discussed in this thread.

http://www.nabble.com/Question-about-client-compatibility-testing-and-DERBY-516-%28paging-Rick-%3A%29%29-t506203.html#a1372016



  was:
Incorporate a run of jdbcapi/Compatibility test into derbyall  with the following combinations:

client                server
10.1.1.0           trunk
trunk                10.1.1.0

This can provide some minimal compatibility testing in derbyall against the original client
release.
It requires that the 10.1.1.0 jars be checked in.  I will file a separate issue for this.
Rick is assigned to the top level issue to integrate testing procedures.   He wrote the test
but there was concern that we actually not adding any coverage for compatibilty because it
only runs with trunk server/ trunk client.

Adding this combination was discussed in this thread.

http://www.nabble.com/Question-about-client-compatibility-testing-and-DERBY-516-%28paging-Rick-%3A%29%29-t506203.html#a1372016



        Summary: Include run of junitTests/CompatibilitySuite, or converted compatibility
test suite with 10.1/trunk combination into suites.All  (was: Include run of junitTests/CompatibilitySuite,
or converted compatibility test suite into suites.All)

Changing the title of this issue to suggest our current test suite.


> Include run of junitTests/CompatibilitySuite, or converted compatibility test suite with
10.1/trunk combination into suites.All
> -------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-1048
>                 URL: https://issues.apache.org/jira/browse/DERBY-1048
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>    Affects Versions: 10.2.1.6
>            Reporter: Kathey Marsden
>
> Incorporate a run of jdbcapi/Compatibility test into derbyall  with the following combinations:
> client                server
> 10.1.1.0           trunk
> trunk                10.1.1.0
> This can provide some minimal compatibility testing in derbyall against the original
client release.
> It requires that the 10.1.1.0 jars be checked in.  I will file a separate issue for this.
> Rick is assigned to the top level issue to integrate testing procedures.   He wrote the
test but there was concern that we actually not adding any coverage for compatibility because
it only runs with trunk server/ trunk client.
> Adding this combination was discussed in this thread.
> http://www.nabble.com/Question-about-client-compatibility-testing-and-DERBY-516-%28paging-Rick-%3A%29%29-t506203.html#a1372016

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message