db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Created: (DERBY-4977) XPLAIN reports negative EXECUTE_TIME for some parts of a join
Date Tue, 18 Jan 2011 10:35:43 GMT
XPLAIN reports negative EXECUTE_TIME for some parts of a join
-------------------------------------------------------------

                 Key: DERBY-4977
                 URL: https://issues.apache.org/jira/browse/DERBY-4977
             Project: Derby
          Issue Type: Bug
          Components: SQL
    Affects Versions: 10.7.1.1
            Reporter: Knut Anders Hatlen
            Priority: Minor


I see that if I execute a join against the system tables with XPLAIN and statistics timing
enabled, some of the rows in SYSXPLAIN_RESULTSET_TIMINGS have negative values in the EXECUTE_TIME
column.

Here are the contents of the SYSXPLAIN_RESULTSET_TIMINGS after two runs with the attached
repro script:

ij> select execute_time from my_schema.sysxplain_resultset_timings;
EXECUTE_TIME        
--------------------
-1                  
0                   
0                   
-6                  
9                   
16                  

6 rows selected

ij> select execute_time from my_schema.sysxplain_resultset_timings;
EXECUTE_TIME        
--------------------
-1                  
1                   
0                   
-7                  
10                  
15                  

6 rows selected

Note the two rows with negative values in both of the examples.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message