db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Myrna van Lunteren <m.v.lunte...@gmail.com>
Subject Re: my build is broken
Date Thu, 04 Nov 2010 18:19:47 GMT
On Thu, Nov 4, 2010 at 11:12 AM, Rick Hillegas <rick.hillegas@oracle.com> wrote:
> Myrna van Lunteren wrote:
>>
>> Hi,
>>
>> My main build on windows is broken after the latest updates. On my
>> Linux machine the build is fine, but I don't have the j2me stuff
>> there, probably some other stuff is missing. Perhaps I should've done
>> clobber before svn update again, but I tried to clean everything up
>> and start over...
>>
>> I'm still trying to see what's happening/happened/fixing it up...
>>
>> e.g.:
>> compile_util:
>>    [javac] Compiling 8 source files to C:\derbyt\svn\trunk\classes
>>    [javac]
>> C:\derbyt\svn\trunk\java\engine\org\apache\derby\iapi\types\SqlXmlUtil.java:40:
>> package org.w3c.dom does not exist
>>    [javac] import org.w3c.dom.Attr;
>>    [javac]                   ^
>>
>> and, more seriously:
>>    [javac]
>> C:\derbyt\svn\trunk\java\engine\org\apache\derby\impl\jdbc\LOBStoredProcedure.java:27:
>> cannot find symbol
>>    [javac] symbol  : class DriverManager
>>    [javac] location: package java.sql
>>    [javac] import java.sql.DriverManager;
>>    [javac]                ^
>>
>>
>>
>> Myrna
>>
>>
>
> I am seeing pages of these build errors as well, when I do "ant clobber"
> followed by "ant build". I tried backing out my recent change to the build
> (1031069, see DERBY-4845), but that did not fix the problem. I think that
> someone else's changes have caused this.
>
> Regards,
> -Rick
>

I was doing "ant all". I noticed (will do some more checking) that the
classes it's complaining about seem to get created at some point
anyway, and if I run ant all a second time, there are no errors...

Myrna

Mime
View raw message