db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4847) Errors should be prompt if using wrong CLASSPATH or JAVA version to make documentation target for release
Date Thu, 14 Oct 2010 14:00:33 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4847?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12920964#action_12920964
] 

Kim Haase commented on DERBY-4847:
----------------------------------

Just to be clear -- the CLASSPATH is the important factor here. It is fine to use Java 1.6
(or 1.5).


> Errors should be prompt if using wrong CLASSPATH or JAVA version to make documentation
target for release
> ---------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-4847
>                 URL: https://issues.apache.org/jira/browse/DERBY-4847
>             Project: Derby
>          Issue Type: Bug
>          Components: Build tools
>    Affects Versions: 10.6.2.1
>            Reporter: Lily Wei
>            Priority: Minor
>             Fix For: 10.7.0.0
>
>
> When making Derby documentation for 10.6.2.1 release, no error was prompt when wrong
version of java is being used or wrong value for CLASSPATH.
> In order to make Derby documentation, the release manager has to use JAVA 1.4.2 or later
and set CLASSPATH to include:  fop.jar, avalon-framework-cvs-20020806.jar, and batik.jar files
located in %DOC_ROOT%/trunk/lib/ for PDF output. When using JAVA 1.6 and wrong CLASSPATH to
build pdf documentation, no error was prompt and no PDF output was created. Error will be
more intuitive that the build was not successful.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message